13: Type mismatch

Published: 2006-08-04

 

Last Updated: 2013-03-08

Applies To

Symptoms

When opening Guard1 Plus

-or-

When Attendant attempts to process a download file (followed by "There was an error trying to process download file...")

-or-

When running a Guard1 Plus SE configuration wizard (e.g. G1DBSetup.exe or G1AttendantConfig.exe)

-or-

When running the Guard1 Plus SE Activate Software wizard (G1ActivateSoftware.exe)

-or-

When attempting to process a download file that contains Numeric Keypad data in Guard1 Plus SE 4.30

 

You receive the following error:

 

Cause

If the error occurs when opening Guard1 Plus, the Windows User Account does not have sufficient permissions.

 

If the error occurs when the Attendant attempts to process a download file, it is generally due to a mismatch in the Regional Settings between the Guard1 Plus PC and the remote Mini-Attendant PC or Attendant SE PC where the PIPE download occurred. The Regional Settings Decimal symbol setting must be the same on both PCs.

 

If Mini-Attendant File Manager (MAFM) is unable to delete DL2 files from the shared folder (usually accompanied by -75: Path/file access error). This results in the same DL2 file being copied to the Guard1 Plus PC multiple times. In this scenario, MAFM appends a copy number to the DL file name to avoid overwriting the original DL2 file (e.g. "DL20100101065439(0).DL2"). The appended copy number corrupts the file's encryption and prevents the Attendant from processing the file, resulting in the 13: Type mismatch error. To resolve:

 

If the error occurs when running a Guard1 Plus SE configuration wizard (e.g. G1DBSetup.exe or G1AttendantConfig.exe):

 

If the error occurs when running the Guard1 Plus SE Activate Software wizard (G1ActivateSoftware.exe), it is due to typographical errors in the Support Code and/or Password entered by the user.

 

If the error occurs when Attendant SE processes a download file containing Numeric Keypad data, it is due to a known issue in Guard1 Plus SE 4.30 and 4.40. If you used Numeric Keypad in an earlier version of Guard1 Plus SE, and you used custom settings for the number of digits for one or more Button types, these custom settings were not transferred to version 4.30/4.40 when you upgraded. This results in Guard1 Plus SE 4.30/4.40 attempting to apply the default scan lengths (2 digits=Officer, 3=Incident, 4=Location) to the custom-length tour data.

 

Resolution

If the error occurs when opening Guard1 Plus, verify that all Windows User Accounts that will be using Guard1 Plus have the following minimum permissions:

 

If the error occurs when the Attendant attempts to process a download file from a remote Mini-Attendant or Attendant SE workstation, verify that the Windows Regional Settings are the same on both PCs, specifically the Decimal symbol setting.  If one PC uses period "." and the other uses comma "," as the Decimal symbol setting it will cause this error.

 

If the error occurs when running a Guard1 Plus SE configuration wizard, uninstall the SE Local Client, then reinstall from the Client\Local Client folder on your Guard1 Plus SE Server share.

 

If the error occurs when running the Guard1 Plus SE Activate Software wizard (G1ActivateSoftware.exe), verify that you entered the Support Code and Password you received from us correctly. The password is case-sensitive.  If you have confirmed that these items are entered correctly and you still receive the error, please contact Technical Support. IMPORTANT: if you received your Support Code and Password via email, the Support Code may be in the format 12345-98765. Use only the first five digits. The rest of the code does not apply to Guard1 Plus SE.

 

If the error occurs when Attendant SE processes a download file containing Numeric Keypad data, verify that you have updated the default Guard1 Plus SE 4.30/4.40 Numeric Keypad scan length options to match your custom options from your previous version. NOTE: you must install the Guard1 Plus Client on the Attendant PC if it is not already installed.

  1. On the affected PC, open the Guard1 Plus Client.
  2. Click View > Guard1 Plus SE Options.
  3. Click the Keypads tab.
  4. Modify the default scan lengths and names as necessary.
  5. Click Save.
  6. Close the Client.
  7. Restart the Attendant.  Your download files should process successfully.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

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