6: Overflow

 

Published: 2005-09-07

 

Last Updated: 2014-03-21

Applies To

Symptoms

When you open Guard1 Plus

-or-

When Attendant begins processing a download file

-or-

When you right-click a Download on the Downloads Tab and select View Download

 

You receive the following error:

 

Cause

If the error occurs when you launch Guard1 Plus:

 

If the error occurs when Attendant begins processing a download file:

 

If the error occurs when right-clicking a Download and selecting View Download:

 

 

Resolution

Important: This article contains information about modifying the Windows Registry. Before you modify the Registry, make sure to back it up and make sure that you understand how to restore the Registry if a problem occurs. For information about how to back up, restore, and edit the Registry, click the following article number to view the article in the Microsoft Knowledge Base:

 

KB256986 (http://support.microsoft.com/kb/256986/) Description of the Microsoft Windows Registry

 

You must be an Administrator to edit the Windows Registry. If you do not have Administrator privileges, or are not familiar with the terms and methods described in the procedure below, please contact your IT Department for assistance.

 

If the error occurs when you open Guard1 Plus, check for an invalid PIPE ManufacturingDate setting in the Registry. The first step is to identify the problem PIPE and report its serial number to Technical Support:

  1. Close Guard1 Plus or OK the "6:" error.
  2. Click Start > Run.
  3. In the Open box type regedit, then click OK. This will open Registry Editor.
  4. On the left side of the screen, navigate to the folder HKEY_LOCAL_MACHINE\Software\TimeKeeping Systems Inc\Guard1 Plus(32-bit) or HKEY_LOCAL_MACHINE\Software\Wow6432Node\TimeKeeping Systems Inc\Guard1 Plus (64-bit).
  5. Under Guard1 Plus, right-click on the Readers folder and select Export.
  6. In the Save As dialog, choose a convenient folder such as My Documents. Enter Readers as the name for the exported file. Change the Save as type from .REG to .TXT (Text files) then click Save. This will create a text file with the contents of the Readers folder. Please email the file to support@guard1.com so that we can identify the problem PIPE for future reference.
  7. Close Registry Editor.

 

To resolve the error:

  1. Follow steps 1-4 above.
  2. Under Guard1 Plus, right-click on the Readers folder and select Delete, then Yes to confirm.
  3. Close Registry Editor.
  4. Open Guard1 Plus. It should open without error. If the problem recurs after downloading your PIPEs, please follow the steps in the Identify the PIPE section above and send us the new copy of the exported Readers key. If the same PIPE is causing the problem, we will issue a Return Merchandise Authorization for it so that you can return it for evaluation and repair.

 

 

If the error occurs when Attendant begins processing a download file:

  1. Verify that the operating system primary language and Regional Settings is the same on both the remote and the Guard1 Plus workstations.
  2. Remove all Unicode characters from PIPE and/or Downloader names.  Device names can contain standard ASCII characters only (i.e., letters and numbers)

 

 

If the error occurs when you right-click a Download on the Downloads Tab and select View Download:

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

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