91: Object variable or With Block variable not set

Published: 2004-12-15

 

Last Updated: 2010-11-04

Applies To

 

Symptoms

When downloading a remote Modem Downloader

-or-

When downloading a PIPE to a Direct Downloader

-or-

When attempting to print or preview a report

-or-

When opening Guard1 Plus 2.x

-or-

When attempting to Archive or Backup your database with the Data Maintenance Wizard

-or-

When launching the Attendant SE

 

You receive the following error:

 

Cause

If the error occurs when downloading a remote Modem Downloader:

 

If the error occurs when downloading a PIPE to a Direct Downloader:

 

If the error occurs when attempting to print or preview a report:

 

If the error occurs when opening Guard1 Plus 2.x:

 

If the error occurs when attempting to Archive or Backup your database:

 

If the error occurs when launching Attendant SE:

 

Resolution

Important: This article contains information about modifying the Windows Registry. Before you modify the Registry, make sure to back it up and make sure that you understand how to restore the Registry if a problem occurs. For information about how to back up, restore, and edit the Registry, click the following article number to view the article in the Microsoft Knowledge Base:

 

KB256986 (http://support.microsoft.com/kb/256986/) Description of the Microsoft Windows Registry

 

You must be an Administrator to edit the Windows Registry. If you do not have Administrator privileges, or are not familiar with the terms and methods described in the procedure below, please contact your IT Department for assistance.

 

If the error occurs when downloading a remote Modem Downloader:

 

If the error occurs when downloading a PIPE to a Direct Downloader:

  1. Close Guard1 Plus.
  2. Click Start > Run, or click in the Search Box if Windows Vista or 7.
  3. Type regedit, then click OK. This will open Registry Editor.
  4. On the left side of the screen, navigate to the folder HKEY_LOCAL_MACHINE\Software\TimeKeeping Systems Inc\Guard1 Plus (32-bit) or HKEY_LOCAL_MACHINE\Software\Wow6432Node\TimeKeeping Systems Inc\Guard1 Plus (64-bit).
  5. Under Guard1 Plus, right-click on the Readers folder and select Delete, then Yes to confirm.
  6. Close Registry Editor.
  7. Open Guard1 Plus and attempt to download the PIPE again. If the error recurs, contact Technical Support; there may be a problem with your PIPE.

 

If the error occurs when attempting to print or preview a report:

 

If the error occurs when opening Guard1 Plus 2.x:

 

If the error occurs when attempting to Archive or Backup your database:

 

If the error occurs when launching Attendant SE:

  1. Close all open programs and shut down Attendant SE.
  2. Click Start > Run.
  3. In the Open box type regedit, then click OK. This will open Registry Editor.
  4. On the left side of the screen, navigate to the folder HKEY_LOCAL_MACHINE\Software\TimeKeeping Systems Inc\Guard1 Plus SE (32-bit) or HKEY_LOCAL_MACHINE\Software\Wow6432Node\TimeKeeping Systems Inc\Guard1 Plus (64-bit).
  5. Under Guard1 Plus SE, right-click on the Downloaders folder and select Delete, then Yes to confirm.
  6. Under Guard1 Plus SE, right-click on the Readers folder and select Delete, then Yes to confirm.
  7. Close Registry Editor.
  8. Launch Attendant SE. NOTE: You may have to run the Add Devices Wizard to re-add your Downloader. After your Downloader is added, your PIPEs will be re-added automatically when they are next downloaded.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2013-2016 TimeKeeping Systems, Inc.