clsDatabase.OpenRecordsetReadOnly -2147217871: Timeout expired

Published: 2014-04-15

 

Last Updated: 2014-04-15

 

 

Applies To

 

Symptoms

When running a Rounds Tracker report (usually the Detail report) you receive the following error:

 

 

After clicking OK at this error you receive another error:

 

 

Clicking OK at the second error closes the error message but Rounds Tracker fails to respond.

 

Cause

It appears that the issue is caused by fragmentation in the indexes of the Button table in the Guard1 Plus SE Application Database.

 

Resolution

Rebuild the indexes of the dbo.Button table in the Guard1 Plus SE Application database.

 

  1. On the SQL Server, open SQL Management Studio and connect to the SQL Instance where the Guard1 Plus SE databases are hosted.

  2. Under Databases, expand the Guard1 Plus SE Application database folder (e.g. "Guard1Plus").

  3. Expand the Tables folder.

  4. Expand the dbo.Button folder.

  5. Right-click Indexes and select Rebuild All.

  6. Click OK. This process may take several minutes.
  7. When the Index rebuild is complete, launch Rounds Tracker and attempt to run the report again.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

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